Java Plug-in Test
Pogo.com's games use the Java plug-in, so if you don't have the Java plug-in installed or you have an out-of-date version, you will not be able to play our games.
The following test will tell you if you have a good version of Java installed on your computer and, if you don't, it will guide you through the update process.